Добро пожаловать на Форум по станкам с ЧПУ!

Помогите с подключением TB6560-V2.0 к nc studio

Тема в разделе "Вопросы бизнеса", создана пользователем apocaliptica, 15 окт 2017.

  1. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    Вот приобрел себе такой наборчик: три драйвера TB6560-V2.0 и nc studio. По печальному прошлому опыту подключения, теперь буду несколько раз перепроверять то что делаю ибо моя прошлая решительность осталась в прошлом вместе с контроллером red TB6560HQT 4V3. Так то в принципе понятно что куда соединять, но лучше уж переспрошу лишний раз. Я сейчас обрисую как я понимаю что куда соединять, а коль что не так, то буду рад если кто поправит.

    [​IMG]
     
  2. IGU

    IGU Member

    Регистрация:
    8 май 2012
    Сообщения:
    859
    Симпатии:
    1
    на картинке не видно что написанно на плате драйвера. Если не перепутал DIR+ и DIR- ну и степ соответственно то должно работать. ТОлько не каждый инвертор можно запрограмировать чтоб включался автоматически. Мне пришлось добавить 3 диода чтоб он включался при выставлении в ncstudio любой скорости.

    [​IMG]

    А в твоем случае при программировании инвертора на старт по сигналу forward он будет постоянно вращаться.скорости меняться будут а выключаться -нет.
     
  3. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
     
  4. IGU

    IGU Member

    Регистрация:
    8 май 2012
    Сообщения:
    859
    Симпатии:
    1
    Это enable . Сигнал который разрешает /запрещает работу драйвера. Полностью снимая напряжение с двигателей . Часто его просто не используют.
     
  5. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    что-то я запутался в подключении. На схеме подключения nc studio, вроде как контакты драйвера которые два вместе соединяются и подключаются к одному разьему на nc studio под номером 15 и рядом написано 5v. Вот нашел как эти драйвера подключают к плате arduino и там эти спаренные контакты подсоединяются к контакту под названием gnd


    [​IMG]
    а на схеме подключения nc studio
    [​IMG]
    Как понять?
     
  6. IGU

    IGU Member

    Регистрация:
    8 май 2012
    Сообщения:
    859
    Симпатии:
    1
    Все верно ардуино у вас подключена" с общим минусом" . NCSTUDIO сделанна с общим плюсом.
    на драйвера есть все выводы . можно и подключать и туда и туда.
    подключайте так:

    [​IMG]
     
  7. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    понял, спасибо огромное!
     
  8. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    все подключил, все работает, завтра буду разбираться с датчиками и настройками шагов и т. д. Спасибо за помощь!
     
  9. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    появилась проблема, греются драйвера. по началу радиаторы были тепленькие, а сейчас прям горячие. Ничего не менялось в настройках. Драйвера на 3 ампера, моторы по 3 ампера. Сами моторы нагревались и нагреваются терпимо градусов до 60. Кто что может подсказать? Уменьшать ток вроде не целесообразно. Или может прицепить на каждый драйвер вентилятор?
     
  10. Podgornov

    Podgornov Member

    Регистрация:
    7 июн 2012
    Сообщения:
    520
    Симпатии:
    0
    Для начала поставить вентилятор, но на максимальном для драйвера токе гонять небезопасно, возможно скоро придется менять.
    Может режим работы станка изменился на более интенсивный?
     
  11. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    греется одна ось Х. Интенсивно работают две оси X и Z. На Y драйвер холодный, но он и не двигается практически. Странно то что, в начале все оси работали без существенного нагрева.
     
  12. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    по ходу дела нарисовалась еще проблемка, сбивается по Z вверх, за три часа на 2.5мм. Шаг 0,06мм, скорость 800мм/мин
     
  13. IGU

    IGU Member

    Регистрация:
    8 май 2012
    Сообщения:
    859
    Симпатии:
    1
    А тут однозначного ответа вряд ли кто даст, ибо причин может быть множество. На форуме есть тема про сбой координат.Почитай.Там много аспектов оговорено.(Виновата может быть как электроника так и механика)
     
  14. gics

    gics Member

    Регистрация:
    7 май 2012
    Сообщения:
    717
    Симпатии:
    0
    Интересно, судя по вопросам на форуме, сбой осей чаще всего происходят именно по Z, какое этому может быть логическое объяснение ?
    Или я ошибаюсь/мне показалось ?
     
  15. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    Кто пользуется или пользовался драйвером шагового двигателя TB6560 V2? Отзовитесь! Сильно ли он у Вас нагревался. Я уже перепрововал все вариации с джамперами на палте и никакого толку. Двигатели подключены 3-х амперные. Может они так устроены, что это их нормальное состояние так нагреваться? Радиатор того драйвера который интенсивнее всего работает, нагревается так что припекает в руку, а тот что почти не используется, вообще прохладный.
     
  16. SNIKERS

    SNIKERS Active Member

    Регистрация:
    19 янв 2013
    Сообщения:
    7.904
    Симпатии:
    1
    По другим координатам не замечают смещения, т.к. привязаться не к чему.
    Если деталь вырежется на 0,5 мм левее / правее - никто этого не заметит.
     
  17. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    проверил механику, все крутится свободно, заэкранировал провод от ШД и заземлил экран. перепробовал разные деления шагов, синусоиды, ток выставлял меньше. Все это никак не повлияло на то что ось Z сбивается за пол часа примерно на 0,3мм вверх. Скорость 3D обработки 700мм/мин. шаг 0,07. фреза 0,2 конусная. Может это драйвера такие и их невозможно настроить? Читал разные темы. Если кто может подкинуть еще что по этому поводу, буду рад.
     
  18. SNIKERS

    SNIKERS Active Member

    Регистрация:
    19 янв 2013
    Сообщения:
    7.904
    Симпатии:
    1
    Нужно проверить муфты, что они не проскальзывают, и не резонируют, если они спиральные.

    И вторая возможная проблема - сбой из за помех между платой управления и драйверами.
    Подключено к NCStudio?
    Провода длинные между платой и драйверами?
    Что-то кроме драйверов к терминальой плате подключено?
    Можно фото подключения?
     
  19. apocaliptica

    apocaliptica Member

    Регистрация:
    5 май 2012
    Сообщения:
    84
    Симпатии:
    0
    плата ncstudio

    [​IMG]
    вот сам станок
    [​IMG]
    вот блок управления

    изначально корпус был плоский, и все было размещено так сказать паралельно друг с другом, но занимало много места, потом решил сделать все более компактным. Поведение станка не изменилось с этой переменной.
    фотки конечно не айс, но как говорится "имеем то что имеем"
    там на противоположной стороне от платы развязки блок питания. Я пробовал и вытягивать драйвера наружу и все ровно Z уходит вверх.
     
  20. technik

    technik Member

    Регистрация:
    6 апр 2012
    Сообщения:
    476
    Симпатии:
    0
    Может оказаться что причина в выходных импульсах NCStudio, фронт/спад. Я в свое время по этой причине отказался от красной NCStudio, правда драйвера у меня Yako.